Training and Resource Center Browser Requirements

Erick Simpson -

The IT Business Builder Training and Resource Center supports the following browsers:

  1. Microsoft Internet Explorer 9+

  2. Google Chrome – latest version

  3. Mozilla Firefox – latest version

  4. Apple Safari - latest version

Have more questions? Submit a request

0 Comments

Article is closed for comments.